|
커피향이 나는 *NIX
커피닉스
시스템/네트웍/보안을 다루는 곳
|
|
|
|
| 이전 주제 보기 :: 다음 주제 보기 |
| 글쓴이 |
메시지 |
darkhi
가입: 2004년 12월 29일 올린 글: 7
|
올려짐: 2005.2.27 일, 10:46 am 주제: vsftpd 계정 로그인이 안됩니다. |
|
|
[R] Connecting to rain9.dnip.net -> IP=192.168.0.1 PORT=21
[R] Connected to rain9.dnip.net
[R] 220 Welcome to rain9.com FTP service.
[R] USER root
[R] 331 Please specify the password.
[R] PASS (hidden)
[R] 530 Login incorrect.
[R] Connection failed
local_enable=YES 되어 있구요.
/etc/ftpusers에도 root 없습니다.
root 뿐만 아니라 다른 계정도 그렇더군요.
스탠드얼론 방식이구요.
몇달전 글인 'vsftp가 접속이 되지 않는 경우'(검색하면 나옴)과 같은 경우 같습니다.
이것은 로그파일입니다.
Sun Feb 27 01:45:00 2005 [pid 13563] [root] FAIL LOGIN: Client "192.168.0.2"
Sun Feb 27 01:45:09 2005 [pid 13566] CONNECT: Client "192.168.0.2"
Sun Feb 27 01:45:10 2005 [pid 13565] [ftp] OK LOGIN: Client "192.168.0.2", anon password "darkhi@paran.com"
익명 접속은 잘 됩니다.
[R] Connected to rain9.dnip.net
[R] 220 Welcome to rain9.com FTP service.
[R] USER anonymous
[R] 331 Please specify the password.
[R] PASS (hidden)
[R] 230 Login successful.
[R] SYST
[R] 215 UNIX Type: L8
[R] FEAT
[R] 211-Features:
[R] EPRT
[R] EPSV
[R] MDTM
[R] PASV
[R] REST STREAM
[R] SIZE
[R] TVFS
[R] 211 End
[R] PWD
[R] 257 "/"
[R] TYPE A
[R] 200 Switching to ASCII mode.
[R] PASV
[R] 227 Entering Passive Mode (61,252,245,150,138,126)
[R] Opening data connection IP: 61.252.245.150 PORT: 35454
[R] LIST -al
[R] 150 Here comes the directory listing.
[R] 226 Directory send OK.
vsftpd-2.0.1.tar.gz을 통해서 컴파일로 설치했습니다. 페도라코어3입니다.
왜 안되는걸까요? 흠... _________________ 사랑을 모르는 나 |
|
| 위로 |
|
 |
플릭 손님
|
|
| 위로 |
|
 |
darkhi
가입: 2004년 12월 29일 올린 글: 7
|
올려짐: 2005.2.27 일, 5:53 pm 주제: 아무 문제 없네요. |
|
|
저 글도 제가 썼었던건데, 그때는 어쩌다가 운좋게 되서 작동했었습니다.
그런데 다시 리눅스를 설치하는 바람에....
pam 인증 거부 하지 않네요.
Feb 27 16:01:01 rain9 crond(pam_unix)[3908]: session closed for user root
Feb 27 16:17:36 rain9 dhclient: DHCPREQUEST on eth0 to 211.174.0.36 port 67
Feb 27 16:17:36 rain9 dhclient: DHCPACK from 211.174.0.36
Feb 27 16:17:36 rain9 dhclient: bound to 61.252.245.150 -- renewal in 3084 seconds.
Feb 27 17:01:01 rain9 crond(pam_unix)[3932]: session opened for user root by (uid=0)
Feb 27 17:01:01 rain9 crond(pam_unix)[3932]: session closed for user root
Feb 27 17:09:00 rain9 dhclient: DHCPREQUEST on eth0 to 211.174.0.36 port 67
Feb 27 17:09:00 rain9 dhclient: DHCPACK from 211.174.0.36
Feb 27 17:09:00 rain9 dhclient: bound to 61.252.245.150 -- renewal in 3025 seconds.
Feb 27 17:51:59 rain9 sshd(pam_unix)[3960]: session opened for user root by root(uid=0)
아무 기록도 안되지만 그래도 다른 내용이 도움이 될까봐 올려봅니다.
/var/log/messages 내용입니다.
그리고 vsftpd.conf 파일을 바꾸면 오류가 떠버립니다.
anonymous_enable=YES
local_enable=YES
write_enable=YES
local_umask=022
anon_upload_enable=YES
anon_mkdir_write_enable=YES
dirmessage_enable=YES
xferlog_enable=YES
connect_from_port_20=YES
xferlog_file=/var/log/vsftpd.log
ftpd_banner=Welcome to rain9.com FTP service.
chroot_list_enable=YES
chroot_list_file=/etc/vsftpd.chroot_list
chroot_local_user=YES
현재는 이렇게 쓰고 있습니다만,
다른 것들을 사용하면 무조건 설정이 잘못됐다며, 한줄 한줄 오류가 뜹니다.
예를 들자면 http://blog.naver.com/hwantagexsw2/2244967
이런걸로 바꿔서 쓰게 된다면, 그냥 오류가 떠버림.
그래서 황당 그 자체네요; _________________ 사랑을 모르는 나 |
|
| 위로 |
|
 |
truefeel 카페 관리자
가입: 2003년 7월 24일 올린 글: 1277 위치: 대한민국
|
올려짐: 2005.2.27 일, 11:41 pm 주제: Re: 아무 문제 없네요. |
|
|
| darkhi 씀: | 저 글도 제가 썼었던건데, 그때는 어쩌다가 운좋게 되서 작동했었습니다.
그런데 다시 리눅스를 설치하는 바람에....
pam 인증 거부 하지 않네요.
Feb 27 16:01:01 rain9 crond(pam_unix)[3908]: session closed for user root
... 생략 ...
Feb 27 17:51:59 rain9 sshd(pam_unix)[3960]: session opened for user root by root(uid=0)
아무 기록도 안되지만 그래도 다른 내용이 도움이 될까봐 올려봅니다.
/var/log/messages 내용입니다.
그리고 vsftpd.conf 파일을 바꾸면 오류가 떠버립니다.
anonymous_enable=YES
local_enable=YES
write_enable=YES
local_umask=022
anon_upload_enable=YES
anon_mkdir_write_enable=YES
dirmessage_enable=YES
xferlog_enable=YES
connect_from_port_20=YES
xferlog_file=/var/log/vsftpd.log
ftpd_banner=Welcome to rain9.com FTP service.
chroot_list_enable=YES
chroot_list_file=/etc/vsftpd.chroot_list
chroot_local_user=YES
현재는 이렇게 쓰고 있습니다만,
다른 것들을 사용하면 무조건 설정이 잘못됐다며, 한줄 한줄 오류가 뜹니다.
예를 들자면 http://blog.naver.com/hwantagexsw2/2244967
이런걸로 바꿔서 쓰게 된다면, 그냥 오류가 떠버림.
그래서 황당 그 자체네요; |
비밀번호는 맞는데 로긴 안되는 경우는 예전에도 답한 것 처럼 PAM 설정이 잘 못된 경우가 대부분입니다.
로긴이 안된 그 상태로 돌아가 작업을 다시 해보실 거면 /etc/pam.d/ 설정을 살펴보세요. |
|
| 위로 |
|
 |
darkhi
가입: 2004년 12월 29일 올린 글: 7
|
올려짐: 2005.2.28 월, 7:35 pm 주제: 정말 감사합니다. |
|
|
pam_service_name=vsftpd
가 빠져서 안되었던거군요.
무식한건 죄라고... 정말 알려주시는데도 못알아먹는 제가 한심하군요;
아무튼 고맙습니다.
저번엔 원인을 몰랐지만 이번엔 원인을 알았으니
앞으로 이런 경우는 없으리라 봅니다 ^_^ _________________ 사랑을 모르는 나 |
|
| 위로 |
|
 |
|
|
새로운 주제를 올릴 수 없습니다 답글을 올릴 수 없습니다 주제를 수정할 수 있습니다 올린 글을 삭제할 수 없습니다 투표를 할 수 없습니다
|
Powered by phpBB © 2001, 2005 phpBB Group
|