|
커피향이 나는 *NIX
커피닉스
시스템/네트웍/보안을 다루는 곳
|
|
|
|
| 이전 주제 보기 :: 다음 주제 보기 |
| 글쓴이 |
메시지 |
졸려 손님
|
올려짐: 2004.2.24 화, 12:07 pm 주제: antivir-milter 관련해서 에러가 발생합니다. |
|
|
좋은진호님의 설정과 제가 sendmail설정을 고쳐서
antivir-milter를 구동시켰습니다.
그런데 제가 저희서버 백업라인(오프라인상태)에서 할때는 아무런 이유없이
잘 되었는데...온라인 상태에서는 구동은 되는데 에러가 납니다.
/var/log/messages 에는
avmilter[4069]: gethostby*.getanswer: asked for "localhost", got "realname" 이런 메세지가 뜨고요.
/var/log/maillog 에는 아래와 같은 오류가 발생합니다.
-------------------------------------------------------------------------------------
Feb 24 09:25:17 mail avmilter[2128]: engine version: 6.23.0.1
Feb 24 09:25:17 mail avmilter[2128]: vdf version: 6.23.0.64
Feb 24 09:25:17 mail avmilter[2128]: running in private mode
Feb 24 09:25:22 mail avmilter[2135]: AntiVirMilter: Unknown host name localhost
Feb 24 09:25:22 mail avmilter[2135]: AntiVirMilter: Unable to create listening socket on conn inet:3333@localhost
------------------------------------------------------------------------------------
당근 localhost는 잡히구요..
/etc/hosts에 127.0.0.1 localhost localhost 설정을 한 상태입니다.
혹시 antivir-milter가 개인에 한해서 쓸수 있는데 저희 메일서버 사용자가
많아서 그런걸까여?
왜 이런 에러가 나고 바이러스 메일이 차단이 안돼는지 아시는분있으면 가르쳐 주세요.
백업라인(오프라인 상태)에서는 제가 여려명으ㅐ 아이디를 사용해서 할때는 문제가 없습니다. |
|
| 위로 |
|
 |
truefeel 카페 관리자
가입: 2003년 7월 24일 올린 글: 1277 위치: 대한민국
|
올려짐: 2004.2.25 수, 8:42 am 주제: Re: antivir-milter 관련해서 에러가 발생합니다. |
|
|
혹시 네임서버를 운영하신가요?
네임서버 설정에서 localhost 에 대한 설정이 빠져서 그럴 수도 있을 것 같습니다.
해서 결과가 어떻게 나오는지 확인해보세요. 네임서버를 운영한다면 /etc/named.conf 에
| 코드: |
zone "localhost" IN { ... 설정 ... }
|
과 같은 설정과 또한 localhost에 대한 존파일을 만들고 해보시기 바랍니다.
또한 /etc/nsswitch.conf 에서 hosts: 부분이 files dns ... 등의 순서인지도 보시구요, 바꾼적없다면 이리 되어 있을겁니다.
Antivir Milter는 개인외에는 구입해서 사용해야한다는 것은 아시죠? 이부분에 대한 책임은 설치하신 분에게 있습니다. |
|
| 위로 |
|
 |
졸려 손님
|
올려짐: 2004.2.25 수, 5:02 pm 주제: 답변 감사드립니다. |
|
|
네임서버는 따름 ip로 돌리고 있습니다.
1차,2차는 웹호스팅 받는 업체거구요.
3차는 저희 네임 서버입니다.
/etc/nsswitch.conf 에는 "hosts: files dns" 이런식으로 되어 잇고요
# dig localhost 는
--------------------------------------------------------------------------------
; <<>> DiG 9.2.1 <<>> localhost
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 65037
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 1
;; QUESTION SECTION:
;localhost. IN A
;; ANSWER SECTION:
realname. 86400 IN A 211.xxx.xx.xxx
;; AUTHORITY SECTION:
realname. 86400 IN NS ns2.xxxx.net.
;; ADDITIONAL SECTION:
ns2.xxxx.net. 86400 IN A 211.yyy.yyy.y
;; Query time: 17 msec
;; SERVER: 211.yyy.yyy.z#53(211.yyy.yyy.z)
;; WHEN: Wed Feb 25 16:54:45 2004
;; MSG SIZE rcvd: 95
--------------------------------------------------------------------------------
이렇게 나오는데..맞는건가여? |
|
| 위로 |
|
 |
|
|
새로운 주제를 올릴 수 없습니다 답글을 올릴 수 없습니다 주제를 수정할 수 없습니다 올린 글을 삭제할 수 없습니다 투표를 할 수 없습니다
|
Powered by phpBB © 2001, 2005 phpBB Group
|