|
커피향이 나는 *NIX
커피닉스
시스템/네트웍/보안을 다루는 곳
|
|
|
|
| 이전 주제 보기 :: 다음 주제 보기 |
| 글쓴이 |
메시지 |
herr 손님
|
올려짐: 2004.9.08 수, 2:09 pm 주제: [perl+mysql] 메일 수신 로그를 DB로 관리하려는데 오류 발생 |
|
|
perl과 mysql을 이용하여 메일 수신 로그를 DB로 관리하려고 합니다.
설치는 아래 사이트들을 참고하였습니다.
- http://coffeenix.net/board_view.php?cata_code=0&bd_code=172
- http://www.perl.co.kr/cgi-bin/mosehan/read_html?html=os/unix/unix_perl_db_install.html
- http://www.perl.com/pub/a/1999/10/DBI.html
* 가장 최신버전으로 설치하였음
그런데...
아래와 같은 에러메세지가 발생합니다.
procmail: Assigning "INCLUDERC=/var/log/mail_log.rc"
procmail: Assigning "MATCH="
procmail: Matched "사용자 <user01@test.co.kr>"
procmail: Match on "^From: \/.*"
procmail: Assigning "FROM=사용자 <user01@test.co.kr>"
procmail: Assigning "MATCH="
procmail: Matched "<user01@test.co.kr>"
procmail: Match on "^To: \/.*"
procmail: Assigning "TO=<user01@test.co.kr>"
procmail: Assigning "MATCH="
procmail: Matched "연습"
procmail: Match on "^Subject: \/.*"
procmail: Assigning "SUBJECT=연습"
procmail: Score: 803 803 "> 1"
procmail: Assigning "LENGTH=803"
procmail: Executing "/var/log/mail_log.pl,사용자<user01@test.co.kr>,<user01@test.co.kr>,user01,연습,803"
/var/log/mail_log.pl: use: not found
/var/log/mail_log.pl: syntax error at line 18: `{' unexpected
procmail: Assigning "RESULT=" |
|
| 위로 |
|
 |
herr 손님
|
올려짐: 2004.9.09 목, 9:49 am 주제: 해답을 찾았습니다. |
|
|
원인은 PATH 설정에 있었습니다.
로그를 보닌깐
mail_log.pl에서 설정된 내용중에
use: DBI 에서 문제가 있다는 것을 확인하였습니다.
그래서 DBI에 대한 경로를 찾아서 PATH를 설정해 주였지요..
그러닌깐.. 잘 되더군요.
혹시 저와 같은 에러가 발생하시는 분은 참고하시기 바랍니다. |
|
| 위로 |
|
 |
|
|
새로운 주제를 올릴 수 없습니다 답글을 올릴 수 없습니다 주제를 수정할 수 있습니다 올린 글을 삭제할 수 없습니다 투표를 할 수 없습니다
|
Powered by phpBB © 2001, 2005 phpBB Group
|