커피닉스, 시스템 엔지니어의 쉼터 커피향이 나는 *NIX
커피닉스
시스템/네트웍/보안을 다루는 곳
* HanIRC의 #coffeenix 방
[ 장비 및 회선 후원 ]
HOME > 네트워크(network) > 네임서버(name server, dns, bind) 도움말
검색 : 사이트 WHOIS 웹서버 종류


  도메인명으로 사용가능한 문자 작성일 : 2008/09/02 18:55
 
  • 글쓴이 : 좋은진호 ( http://coffeenix.net/ )
  • 조회수 : 11829
          [ 이전화면 / 수정 ]   비밀번호 :     인쇄용 화면
      제  목 : 도메인명으로 사용가능한 문자
    작성자 : 좋은진호(truefeel, http://coffeenix.net/ )
    작성일 : 2008.8.12(화)

    다국어 도메인(IDN)이 아닌 일반적인 도메인의 경우 다음과 같은 문자만 사용해야 한다.

    - 영문자(a-z)
    - 숫자(0-9)
    - 하이픈(-)
    - 점(.)

    RFC 952(DOD INTERNET HOST TABLE SPECIFICATION)를 살펴보면 도메인명(호스트명)으로 a-z, 0-9, -, . 를 사용하도록 되어 있다. 그리고, 첫번째문자는 영문자이어야 하고, 마지막 문자는 -나 . 이 들어갈 수 없다.

    http://www.ietf.org/rfc/rfc952.txt
     A "name" (Net, Host, Gateway, or Domain name) is a text string up
       to 24 characters drawn from the alphabet (A-Z), digits (0-9), minus
       sign (-), and period (.).  Note that periods are only allowed when
       they serve to delimit components of "domain style names". (See
       RFC-921, "Domain Name System Implementation Schedule", for
       background).  No blank or space characters are permitted as part of a
       name. No distinction is made between upper and lower case.  The first
       character must be an alpha character.  The last character must not be
       a minus sign or period.
     


    RFC 1033(DOMAIN OPERATIONS GUIDE)에는 under bar(_, underscore)문자를 사용하는 것도 얘기를 하고 있지만, SMTP 등 프로토콜에 따라서 사용할 수 없는 경우가 있으니 _ 문자는 사용하지 말기를 바란다.

    http://www.ietf.org/rfc/rfc1033.txt
     The domain system allows a label to contain any 8-bit character.
       Although the domain system has no restrictions, other protocols such
       as SMTP do have name restrictions.  Because of other protocol
       restrictions, only the following characters are recommended for use
       in a host name (besides the dot separator):

               "A-Z", "a-z", "0-9", dash and underscore
     


    주위 사람이 도메인을 못 찾는 경우가 있다고 해서 도메인이 어떻게 되냐고 물어보니 undercore(_) 문자가 포함되어 있었다. 이를테면 auth_under.coffeenix.net 처럼 설정되어 있었던 것이다. 그래서 이런 경우는 'Non-recoverable failure in name resolution' 메시지를 뿌리면서 도메인을 못 찾는 경우가 있으니, under bar(_)를 사용하지 말거나 under bar(_) 대신 하이픈(-)를 사용하라고 얘기해줬다.
      커피닉스 카페 최근 글
    [11/06] World News Digest:
    [06/16] [질문]SAN 스위치 브로드케이드 dcx8510-4 장비관련입니다.
    [04/22] Re: 영화속에 컴퓨터 이야기 ~스워드피쉬(2001)
    [10/20] Cross Compiler 깔
    [07/14] SSL АО
    [04/26] Re: 도스화면 원격조종 여부
    [04/25] 도스화면 원격조종 여부
    [10/30] Cshell에서 난수 설정
    [10/23] 공항철도주식회사 SE 구인 件
    [01/26] Re: wget으로 다른서버에있는 디렉토리를 가져오려고합니다.
    [01/25] wget으로 다른서버에있는 디렉토리를 가져오려고합니다.
    [01/11] 특정 안드로이드 WebView 버전에서 SSL 문제 (WebView 버그)
    [08/01] DNS forwarder (전달자) 서버를 통해서 쿼리하면 역방향을 받아오질 못합니다.
    [05/16] (주)후이즈 시스템엔지니어 (경력자) 모집
    [02/15] [AWS] Cloudfront edge 확인하기
      New!   최근에 등록한 페이지
      KiCad EDA Suite project (Free/Libre/Open-Source EDA Suite) (CAD)
      오픈캐스케이드 캐드 (OpenCASCADE CAD)
      QCad for Windows --- GNU GPL (Free Software)
      The Hello World Collection
      IPMI를 활용한 리눅스 서버관리
      DNS 설정 검사
      nagiosgraph 설치 방법
      Slony-I 설치 방법 (postgresql replication tool)
      Qmail기반의 Anti spam 시스템 구축하기
      clusterssh

    [ 함께하는 사이트 ]




    운영진 : 좋은진호(truefeel), 야수(yasu), 범냉이, sCag
    2003년 8월 4일~